Pamēģināju beidzot Flatpak lietotnes. Ir jau it kā forši, ja, piemēram, uz LMDE, kas pēc būtības ir tas pats Debian Stable, tikai ar Linux Mint odziņām, vari darbināt jaunākās versijas e-pasta klientprogrammas Evolution vai Geary, bet no otras puses…

Kā jau useris vulgaris, nolēmu to softu uzinstalēt un kādu brītiņu dzīvoju pārliecībā, ka tas viss ir uzinstalēts manā home direktorijā, jo instalācijas procesā nekādas paroles man neprasīja…. Beigās izrādījās, ka tas flatpaks ir bez problēmām ieinstalējies /var/lib direktorijā!!!!! Līdz ar to brīdinājums pārējiem nezinīšiem – instalējiet tikai tās lietotnes, par kuru izcelsmi esiet 101% pārliecināti!!! 😀

Par Flatpak šausmām atrodami arī raksti internetā. Kas mani izbrīna? Tas, ka respektablā Debian GNU/Linux veidotāji kaut ko tādu iekļāvuši oficiālajos repozitorijos…

Iznākusi biroja programmatūras LibreOffice jaunākā versija. Starp dažādiem uzlabojumiem esam sagaidījuši arī lietotāja saskarnes izmainīšanas iespējas. Programmu iespējams uzinstalēt no mūsu repozitorija, instalējot pakotni libreoffice-meta-package.

Steam ir viens no pirmajiem mega-servisiem, kas pievērsās spēļu režīma nodrošināšanai Linux vidē. Atceros laiku pirms gadiem 10, kad Windows vides lietotāji kā argumentu pret Linux piesauca nopietnu spēļu neesamību Linux vidē.

Nu viss ir mainījies. Nu jau kādu laiku Steam servisā Linux vides lietotājiem ir pieejama opcija – ieslēgt emulatoru Proton. Tas paredzēts Windows-only spēļu spēlēšanai. Sākumā viss bija bērnu autiņos, bet nu ir citādi. Izmēģinot jaunāko pieejamo Proton versiju, arī uz LMDE3 ar repozitārijos pieejamo NVIDIA draiveri nav nekādu problēmu uzbliezt tādas spēles kā Call of Duty, Stalker vai Age Of Empires HD. 🙂

LMDE3 ir buvēts uz Debian 9 bāzes. Kā mums rāda pakotņu meklētājs Debian vietnē, skeneru darbināšanai tajā izmantota 1.0.25-4.1 versijas libsane versija. Diemžēl šajā versijā nav Canon LiDE 120 atbalsta. Tīmeklī ir daudz dažādu eksperimentu aprakstu, taču patiesībā viss ir vienkārši – mūs interesējošā – 1.0.27 pakotne ir pieejama testing repozitorijā. Tāpēc daudz nedomāju un uzkompilēju minētās versijas pakotnes lietošanai uz LMDE3. Tās ir pieejamas repozitorijā.

Blaknes: kompilētas ir tikai 64-bit pakotnes. Ja nepieciešamas 32-bit, tad jākompilē pašam 🙂

Linux Mint forumā nu jau kādu laiku ir atrodama manis izveidota diskusija par lāzernieka Canon LBP2900 darbināšanu uz Linux Mint 19 un 19.1. Esmu tur aprakstījis problēmu, sistēmas konfigurāciju utt. Diemžēl pagaidām risinājuma nav. Jāpiezīmē, ka printeris normāli darbojas gan uz Mint 18, gan LMDE3, gan Ubuntu 18.04 un 18.10, tā kā kaut ko sačakarējuši Mint koderi kaut kur saknē. Mēģināju kaut ko eksperimentēt ar Apparmor, bet pagaidām nekādu rezultātu.