LMDE3 ir buvēts uz Debian 9 bāzes. Kā mums rāda pakotņu meklētājs Debian vietnē, skeneru darbināšanai tajā izmantota 1.0.25-4.1 versijas libsane versija. Diemžēl šajā versijā nav Canon LiDE 120 atbalsta. Tīmeklī ir daudz dažādu eksperimentu aprakstu, taču patiesībā viss ir vienkārši – mūs interesējošā – 1.0.27 pakotne ir pieejama testing repozitorijā. Tāpēc daudz nedomāju un uzkompilēju minētās versijas pakotnes lietošanai uz LMDE3. Tās ir pieejamas repozitorijā.

Blaknes: kompilētas ir tikai 64-bit pakotnes. Ja nepieciešamas 32-bit, tad jākompilē pašam 🙂

Linux Mint forumā nu jau kādu laiku ir atrodama manis izveidota diskusija par lāzernieka Canon LBP2900 darbināšanu uz Linux Mint 19 un 19.1. Esmu tur aprakstījis problēmu, sistēmas konfigurāciju utt. Diemžēl pagaidām risinājuma nav. Jāpiezīmē, ka printeris normāli darbojas gan uz Mint 18, gan LMDE3, gan Ubuntu 18.04 un 18.10, tā kā kaut ko sačakarējuši Mint koderi kaut kur saknē. Mēģināju kaut ko eksperimentēt ar Apparmor, bet pagaidām nekādu rezultātu.

Priekš LMDE nedaudz pārkompilēju eParakstītāja pakotnes, kas atrodamas oficiālajā repozitorijā – izravēju no kontroles failiem norādes uz precīzām dependencies versijām, lai bez sāpēm var normāli instalēt, bet… konstatēju, ka vismaz manā gadījumā ir problēmas eParakstītāja saziņā ar karšu lasītāju. Komplektā esošais Pin-Tool kartes saturu redz korekti, tā kā ar kaut kādām permīcijām problēmu nav. Sarakstījos ar eParaksta tehnisko atbalstu – viņi solījās sazināties ar koderiem un problēmu novērst.